FAQs

What to do if there is no history data from the Tapo temperature and humidity sensor

As an owner of the Tapo temperature and humidity sensor T310 or T315, not only can you observe real-time temperature and humidity within the app, but you can also review the historical data to understand the daily, monthly, and yearly changes.

How to export history data from Tapo temperature & humidity sensor

If you notice there is no history data recorded in the Tapo App, or the data stops uploading, the following tips may help to resolve the concerns.

Note: Tapo hub should remain connected to the internet to upload and store Tapo T310/T315’s history data. Data from any power outage period will be lost.

  1. Attempt to manually alter the temperature or humidity in the sensor's surroundings to observe real-time changes in the app. For example, cover the sensor’s top vent hole with your hand, or blow air towards the vent.

If no changes occur, there might be a connectivity issue between the sensor and the hub. Refer to the suggestions here to improve sensor’s connection: How to improve the connection stability of my Hub and its sub-devices (FAQ: https://www.tp-link.com/support/faq/3595/)

How to check the signal strength of the sensor?

Go to Device Settings in the Tapo App -> Device Info -> Tap the signal icon to check the Signal Strength value (RSSI rate).

  • Strong: more than -50 dBm
  • Good to Average: among -70 dBm to-50 dBm
  • Poor: less than -70 dBm

Note: the signal is too weak when it is less than -70dBm, and it is likely to cause a disconnection problem.

  1. Restart the router, wait for 30 minutes then check if the data in the Tapo App has resumed normal recording.
  2. Check if the router has any firewall or ad-blocker settings that might block access to TP-Link servers, preventing the hub from uploading data to the cloud. Disable or remove these settings then monitor future data records.
  3. Change router DNS to 8.8.8.8 and 8.8.4.4.
  4. Restart the Tapo hub.

(Note: unuploaded history data will be deleted after rebooting the tapo hub.)

TP-LINK